Бюджет Блиц для Android - Возьмите расходы под контроль

Ошибка SDBL: Выход за пределы размерности результата

Страницы: 1

С чем это может быть связано?

"В процессе обновления информационной базы произошла критическая ошибка.
по причине:
Ошибка SDBL:
Выход за пределы размерности результата"


давайте больше подробностей.

Ответили: (3)

(2) andrewks,
В копии быза были сделаны изменения. Добавлен новый регист и в двух документах добавлено движение по этому регистру. Теперь при объединении конфигураций и обновлении информационной базы выдается сообщение.

Ответили: (4)

(3) 2791, кэш чистили? на другом компьютере обновить базу пробовали? какой релиз платформы (там, где стоит база, и там, где меняли)?

Ответили: (5) (6)

(4) andrewks,
релиз платформы одинаковый. в данный момент пробую обновить с другого компа, появилось предположение, что возможно это из-за ограничения оперативки.


(4) andrewks,
все перепробовала, не обновляется.

Ответили: (7)

(6) 2791, и всё-таки, какой релиз платформы используется? попробуйте на 8.2.16, если ниже. и ещё, в сети советуют очистить таблицу изменений
ПланыОбмена.УстановитьГлавныйУзел("00");
ПланыОбмена.УстановитьГлавныйУзел(Неопределено);
http://nastroy-ka.ru/system1c/128-qsdbl-q-.html

Ответили: (8)

(7) andrewks,
платформа 8.2.16.352
остальное сейчас смотрю

Ответили: (9) (10)

(8) если файловый вариант выполните chdbfl.
Если серверный выгрузка -> загрузка -> перезапуск агента.
Мне помогло.


(8) 2791, только сперва выполните эти операции на копии, а не на боевой базе. и у вас РИБ используется?

Ответили: (11)

(10) andrewks,
РИБ не используется

Ответили: (12)

(11) 2791, тогда можно смело пользоваться советом по очистке таблиц изменений


Учимся использовать гугл:
1) Решение Номер раз
2) Решение Номер два


Тут еще веселее. Получил конфу в коробке от раруса. При загрузке демки на сервер выползает выше указанная ошибка. Спецы раруса навязывают выезд своего на исследование. Причем загрузка в файловую версию проходит гладко и без запинок.
1. Движок везде одинаковый (версионность).
2. Лечение файловой версии и повторная попытка загрузки "вылеченной" версии привело к выше указанному результату.
3. На тонком клиенте, в файловой версии и пустом пользовательском интерфейсе, при попытке открыть список регламентных заданий приводит к той же ошибке. Настроил пользовательский вид до уровня "с картинками и меню", список заданий стал открываться. На радостях попробовал загрузить в серверную версию - фигвам. (

Проблема не решена.


решена проблема обновлением платформы на 8.2.19.80


Возникла такая же ошибка после обновления конфигурации.
Вылечилось удалением всех изменений из плана обмена.


Начал вспоминать что случилось ...
до применения изменений не смог выгрузить базу из конфигуратора , писало ошибку разделенного доступа , хотя в базе не было никого и в сеансах в 1С консоли тоже чисто было. Сделал бэкап SQL и пошел применять изменения ... вылезла ошибка ...

Перезапустил 1С сервер и помогла Выгрузка / загрузка (даже не с примененной конфигурацией)- благо база 1,5 Гб.

Ну скорее всего сеанс на сервере какой-то остался на момент применения изменений ...

Изменено: valex1c - 25.07.14 0:56


в распределенной базе такая ошибка часто может возникать когда изменяются типы реквизитов или "иерархичность"

от такой ошибки можно попробовать избавиться удалением регистрации изменений (предварительно сделав нужные обмены)
когда много планов обмена, то может понадобиться обработка с кодом:

для каждого план из Метаданные.ПланыОбмена цикл
Запрос = Новый Запрос;
Запрос.Текст =
"ВЫБРАТЬ
| Планы.Ссылка как Узел
|ИЗ
| ПланОбмена."+план.Имя+" КАК Планы";

РезультатЗапроса = Запрос.Выполнить();

ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();

Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
узел = ВыборкаДетальныеЗаписи.Узел;
если узел = ПланыОбмена[план.Имя].ЭтотУзел() тогда
Продолжить;
КонецЕсли;
ПланыОбмена.УдалитьРегистрациюИзменений(узел, Неопределено);
КонецЦикла;
КонецЦикла;


Если и это не помогает то очистить таблицу регистрации изменений на уровне sql:

use Имя_Базы
delete from dbo._ConfigChngR
delete from dbo._ConfigChngR_ExtProps


последний вариант у меня помогло на платформе 1С:Предприятие 8.3 (8.3.5.1119)


Была такая проблема на БП 3.0
1. В базе были изменения структуры;
2. Присутствовала периферийная база.

У меня ошибка возникала в момент обновления конфигурации БД.
Пробовал все перечисленные методы не помогло.
Решалось только закрытием конфигурации перед обновлением конфигурации базы данных

1. Конфигурация -> Закрыть конфигурацию (если открыта);
2. Закрыть конфигуратор;
3. Открыть конфигуратор;
3. Обновить конфигурацию БД (обязательно с закрытой конфигурацией)

Изменено: Исключение - 25.09.14 18:37

+ 4 [ fiyona; lm-alex; mms76; timoorm; ]

Мне тоже помогла уловка с закрытием конфигурации. Мучился 3 недели. Спасибо большое за подсказку


Закрываю конфигурацию- закрываю конфигуратор - открываю конфигуратор конфугурация открыта! База серверная . Возможно нужно чистить кэш на сервере. Просто закрытие конфигурации не помогает.

Помогла очистка таблиц на скуле! спасибо

"use Имя_Базы
delete from dbo._ConfigChngR
delete from dbo._ConfigChngR_ExtProps"

Изменено: vova329 - 08.10.14 13:45


Помог перезапуск службы сервера 1с

Страницы: 1
Форма ответов
Логин:
Пароль:
Текст сообщения*
Прикрепить файл
Охрана труда для 1С:Предприятия 8. Новая версия 6.0.1.1
Открыть