Ошибки при синхронизации РИБ розница 2.2

1. Алексей (user655644_a.slepcov) 14.12.16 10:19 Сейчас в теме
У нас есть две розницы 2.2 одна у нас главный узел, другая подчиненный. Периодически стали возникать ошибки такого рода, что при синхронизации данные из подчиненого узла иногда теряются, это происходит не всегда, и не понятна причина этого. При этом данные из основного узла в подчиненный доходят без сбоев. Подскажите в чем может быть проблема, создавать новый РИБ мы не можем, так как филиал находиться далеко и не понятно какие данные попали в основной узел, какие нет.
Найденные решения
4. Lenochka Semicova (lenochka-semicova) 14.12.16 15:28 Сейчас в теме
Попробуйте проверить - есть ли у Вас в конфе такое изменение

в модуле ОбменДаннымиСервер заменить строки кода


Если СозданиеНачальногоОбраза Тогда
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоОбъектовВБазе(Получатель);
Иначе
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоЗарегистрированныхОбъектов(Получатель);
КонецЕсли;

на


КоличествоОбъектовКВыгрузке = 0;
Если СозданиеНачальногоОбраза Тогда
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоОбъектовВБазе(Получатель);
КонецЕсли

Прогресс-бар при этом будет показывать 0 во время выгрузки, но данные теряться не будут.

Подробнее можно почитать тут
https://partners.v8.1c.ru/forum/topic/1508697
Остальные ответы
2. Alx Alx (alxarz) 28 14.12.16 14:21 Сейчас в теме
проблема может быть из-за "проблемной" базы. ТиИ в помощь.
3. борян петров (TODD22) 15 14.12.16 14:41 Сейчас в теме
(1)Та же проблема. В ЦБ из регистра сведений часть записей не выгружается в узел.....
4. Lenochka Semicova (lenochka-semicova) 14.12.16 15:28 Сейчас в теме
Попробуйте проверить - есть ли у Вас в конфе такое изменение

в модуле ОбменДаннымиСервер заменить строки кода


Если СозданиеНачальногоОбраза Тогда
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоОбъектовВБазе(Получатель);
Иначе
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоЗарегистрированныхОбъектов(Получатель);
КонецЕсли;

на


КоличествоОбъектовКВыгрузке = 0;
Если СозданиеНачальногоОбраза Тогда
КоличествоОбъектовКВыгрузке = РассчитатьКоличествоОбъектовВБазе(Получатель);
КонецЕсли

Прогресс-бар при этом будет показывать 0 во время выгрузки, но данные теряться не будут.

Подробнее можно почитать тут
https://partners.v8.1c.ru/forum/topic/1508697
Оставьте свое сообщение